Simulator crashes - Windows "Not Responding" message

Moderator: Virt

Old Steve
Master Class
Posts: 20
Joined: Mon Sep 21, 2015 10:37 am

Simulator crashes - Windows "Not Responding" message

Postby Old Steve » Fri Oct 30, 2015 5:07 pm

I just installed the latest version and tried to test a very simple little code snippet, and the simulator crashes completely, with a Windows "Not Responding" message, when this "PIND^=(1<<2);" is executed while stepping through.
This does the same:- "PIND=PIND^0b00000100;"

Also, the simulator fails to recognise PD2, and after it tells me with a message, clicking [Edit] also crashes the simulator.
(ATMega328P / UNO )

The code:-

Code: Select all

// Simulate(Uno)
void setup()
    DDRD|=0b00000100;       // Make pin 2 an output.

void loop()
//    PIND^=(1<<PD2);       // Tried this first, simulator won't recognise PD2 then crashes on [Edit] press.
    PIND^=(1<<2);           // Crashes the simulator, (it locks up).
//    PIND=PIND^0b00000100; // This crashes the simulator too, same as above line.

Site Admin
Posts: 240
Joined: Thu Feb 02, 2012 6:07 pm

Re: Simulator crashes - Windows "Not Responding" message

Postby Simulator_admin » Wed Mar 02, 2016 10:41 am

Yes, this is a known problem in v1.01. We have since release v1.01D which addresses most of these crashing issues.

Return to “Version 1.00”

Who is online

Users browsing this forum: No registered users and 1 guest